Front download page currently unavailable

Incident Report for Front

Resolved

This incident has been resolved.
Posted Dec 30, 2022 - 22:15 UTC

Investigating

https://front.com/download is currently unavailable
Posted Dec 30, 2022 - 20:26 UTC
This incident affected: App.