Delays receiving emails from Gmail and Office channels in [us-west-2]

Incident Report for Front

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 18:10 UTC

Monitoring

Delays are resolved for both Gmail and Outlook channels. We're continuing to monitor to ensure we're at a stable steady-state.
Posted Feb 23, 2026 - 16:48 UTC

Update

Office delays have been resolved. Gmail delays have reduced further (to approximately 1 minute).
Posted Feb 23, 2026 - 16:36 UTC

Update

Delays have been reduced, but remain slightly elevated. We are continuing to investigate.
Posted Feb 23, 2026 - 15:51 UTC

Investigating

Some customers are experiencing delays in inbound messages being received from Gmail and Office channels (typically 2-4 minutes of delay). We are currently scaling up our systems to address this.
Posted Feb 23, 2026 - 15:17 UTC
This incident affected: Gmail and O365.