Microsoft Office365 Incident

Incident Report for Front

Resolved

Microsoft is still reporting service degradation, but it's not impacting Front. We'll continue monitoring the situation in case it changes.
Posted Jan 23, 2026 - 05:36 UTC

Monitoring

Microsoft appears to have recovered, and we're no longer seeing any impact on Office 365 channels. All pending messages have been delivered. We're continuing to monitor the situation closely.
Posted Jan 23, 2026 - 03:28 UTC

Identified

Microsoft Office365 is experiencing an outage affecting some Front channels: "Users may be seeing degraded service functionality or be unable to access multiple Microsoft 365 services." Front is unable to send or receive messages for affected customers. Their status page is available at https://status.cloud.microsoft/.
Posted Jan 22, 2026 - 20:49 UTC
This incident affected: O365.