Delay in rules and deliverability of emails for customers [us-west-1]
Incident Report for Front
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 14:37 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 10, 2023 - 14:25 UTC
Monitoring
A fix has been implemented and the delay is going down. We are continuing to monitor the results.
Posted Nov 10, 2023 - 14:07 UTC
Investigating
We are experiencing a 30 minute delay. We are currently investigating this issue.
Posted Nov 10, 2023 - 13:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2023 - 12:57 UTC
Identified
Customers should expect some delay in delivery of new inbounds.
Posted Nov 10, 2023 - 11:47 UTC
This incident affected: Rules and Workflows, Gmail, and O365.