Inbound message delays

Incident Report for Front

Resolved

Delays for inbound messages on O365 and Yalo have been resolved
Posted 3 years ago. Mar 23, 2022 - 17:42 UTC

Investigating

We are currently investigating inbound message delays for O365 and Yalo [office365|yalo_wha][us-west-1]
Posted 3 years ago. Mar 23, 2022 - 17:25 UTC
This incident affected: O365.