Sending and receiving via O365 inboxes unavailable for some customers

Incident Report for Front

Resolved

All channels are back online and all messages have been imported.
Posted Nov 30, 2022 - 03:00 UTC

Update

All missed messages have been imported. We're continuing to monitor the situation closely.
Posted Nov 30, 2022 - 02:58 UTC

Monitoring

All affected channels are back online and we are importing all missed messages.
Posted Nov 30, 2022 - 02:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 30, 2022 - 02:22 UTC
This incident affected: O365.