Front is continuing to partner with Microsoft to investigate the channel sync failures. The next update will be within the next 6 hours. Manually re-authorizing the channel in Front's channel settings has worked in some cases, but not all. Please contact support@front.com for assistance.
Posted May 29, 2026 - 10:42 UTC
Update
Front is continuing to partner with Microsoft to investigate the channel sync failures. The next update will be within the next 8 hours. Manually re-authorizing the channel in Front's channel settings has worked in some cases, but not all. Please contact support@front.com for assistance.
Posted May 29, 2026 - 02:05 UTC
Update
Front is partnering with Microsoft to investigate the channel sync failures and will continue to update here as we make progress. Manually re-authorizing the channel in Front's channel settings has worked in some cases, but not all. Please contact support@front.com for assistance.
Posted May 28, 2026 - 23:36 UTC
Update
Front continues to investigate paths to restore access for affected Office365 channels. Office reports internal errors, which we are trying to work around.
Posted May 28, 2026 - 19:35 UTC
Identified
We are attempting a mitigation step to get impacted channels back online.
Posted May 28, 2026 - 18:57 UTC
Investigating
We are currently investing an issue where a subset of customers are seeing offline O365 channels.