Office365 login issues [office365]
Incident Report for Front
Resolved
This issue has been resolved and all Office365 channels should be functioning normally.
Posted Sep 29, 2020 - 04:59 UTC
Monitoring
Microsoft has taken measures to restore access to Office365 and continues to work towards a complete resolution. We will continue to monitor and ensure that all Office365 inboxes in Front are operating as normal.
Posted Sep 29, 2020 - 01:41 UTC
Identified
Microsoft has updated its status page: https://status.office365.com/
Posted Sep 28, 2020 - 22:00 UTC
Investigating
Office365 has acknowledged issues, affecting multiple services of O365.
Login is currently affected, and incoming messages can be delayed
Posted Sep 28, 2020 - 21:48 UTC
This incident affected: O365.