Delays in receiving messages for some Office365 emails
Incident Report for Front
Resolved
All Office365 email channels have been restored to working status.

We are re-synchronizing all affected channels to ensure that any missed messages have been correctly imported, which should complete gradually over the next hour.
Posted 24 days ago. Sep 19, 2019 - 22:03 UTC
Monitoring
We have imported all messages and we are monitoring the situation
Posted 24 days ago. Sep 19, 2019 - 17:43 UTC
Identified
We identified the issue and we are working on importing those delayed messages.
Posted 24 days ago. Sep 19, 2019 - 17:19 UTC
Investigating
We are currently investigating delays in receiving emails for some Office 365 channels.
Posted 24 days ago. Sep 19, 2019 - 16:52 UTC
This incident affected: Sync engine.