Delays in receiving new email messages on Office 365 and loading the app
Incident Report for Front
Resolved
This incident has been resolved.
Posted Jul 06, 2022 - 16:30 UTC
Identified
The issue has been identified and a fix is been released.
Posted Jul 06, 2022 - 16:05 UTC
Investigating
The team is investigating a few minutes delay in receiving new email messages.

[us-west-1]
Posted Jul 06, 2022 - 15:30 UTC
This incident affected: App and O365.