[office365] Channel Reauthentication Errors
Incident Report for Front
Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 23:02 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 03, 2024 - 22:27 UTC
Monitoring
Front has run a command to restore the Office365 channels that were disconnected, and is now monitoring for any additional errors. Any channels that were successfully manually reconnected during the last few hours were untouched, and should still be operational. If and channels were manually reconnected but received an error, Front is unable to automatically reconnect them. This is rare. Please follow the standard instructions for reconnecting these channels.
Posted Jan 03, 2024 - 22:04 UTC
Update
We are continuing to work on automatically reconnecting all the Office265 channels that were disconnected. Note that if you attempted to reconnect a channel and were unable to, Front will no longer be able to restore the authenticate (as any attempt to manually re-authenticate will overwrite the stored tokens).

Customers can still manually reconnect any channels at any time. Please make sure to follow the guidance in https://help.front.com/en/articles/2043
Posted Jan 03, 2024 - 20:47 UTC
Identified
We're seeing improvements for manual reauthentication attempts. When reauthenticating, please follow the steps outlined on https://help.front.com/en/articles/2043 and ensure that you are reauthenticating with the correct credentials for the channel.
Posted Jan 03, 2024 - 19:05 UTC
Investigating
We are getting reports that some customers are still seeing unexpected permissions errors when reauthenticating O365 channels manually. We're investigating why these reauthentication attempts are failing.
Posted Jan 03, 2024 - 18:10 UTC
Update
We are working on automatically reauthenticating any channels that were affected. In the meantime, customers should be able to manually reauthenticate their O365 channels.
Posted Jan 03, 2024 - 17:29 UTC
Monitoring
We identified an issue where Office365 channels that needed authentication were not able to do so and put the channel into a blocked state. We found the root cause and have deployed a fix.
Posted Jan 03, 2024 - 17:13 UTC
This incident affected: O365.