SendGrid outbound emails delayed
Incident Report for Front
Resolved
SendGrid has informed us that the incident has been fully resolved.
Posted 3 days ago. Oct 10, 2019 - 21:12 UTC
Monitoring
SendGrid reports that they have identified and implemented a fix for the issue causing outbound mail delays. Continuing to monitor.
Posted 3 days ago. Oct 10, 2019 - 20:20 UTC
Identified
SendGrid is experiencing an incident which is leading to outbound email delays for some customers. We're investigating and will provide updates as we have them.
Posted 3 days ago. Oct 10, 2019 - 19:54 UTC
This incident affected: SendGrid.