Office 365 delays
Incident Report for Front
Resolved
Incident is solved.
Posted 3 months ago. Sep 05, 2018 - 08:32 UTC
Monitoring
We are no longer seeing delays in Office 365 incomings in the US region, we keep monitoring the issue.
Posted 3 months ago. Sep 04, 2018 - 16:55 UTC
Identified
Microsoft seems to have issues with a datacenter, explaining the delays we are experiencing. Not all customers are impacted.
Microsoft offers more information on their status page: https://status.office365.com/ and through your Office Admin Portal.
Posted 3 months ago. Sep 04, 2018 - 13:43 UTC
Investigating
We are currently investigating delays in Office 365 incomings in the US region. We are checking with Microsoft directly.
Posted 3 months ago. Sep 04, 2018 - 13:32 UTC
This incident affected: App.