Delegated inboxes not visible

Incident Report for Front

Resolved

We have restored delegated inboxes. If delegated inboxes are not currently visible, please restart the application.
Posted Dec 01, 2025 - 22:26 UTC

Update

We are continuing to work on a fix for this issue.
Posted Dec 01, 2025 - 22:25 UTC

Identified

We have identified an issue where delegated inboxes are not appearing in the navigation panel. We are working on a fix for this issue and will provide another update once there is an ETA for the resolution.
Posted Dec 01, 2025 - 22:18 UTC
This incident affected: App.