Delayed inbound mail for some Office365 inboxes [office365]
Incident Report for Front
Resolved
This incident has been resolved and all Office365 connections are fully operational. We are working on a long-term preventative measures.
Posted Sep 10, 2021 - 01:40 UTC
Monitoring
We are continuing to monitor an issue causing delays for inbound messages for some Office365 email channels. We have a mitigation in place to minimize service disruption and are working on a long-term resolution.
Posted Sep 03, 2021 - 22:09 UTC
This incident affected: O365.