Delays in sending messages
Incident Report for Front
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 22, 2018 - 20:38 UTC
Identified
We are experiencing delays in sending messages.
Posted about 2 months ago. Oct 22, 2018 - 20:26 UTC
This incident affected: SendGrid.