Front is less responsive for some customers in us-west-1 [us-west-1][by-company-00017]
Incident Report for Front
Resolved
This incident has been resolved.
Posted Aug 31, 2023 - 16:55 UTC
Identified
We have identified a potential cause, and are beginning to see the app's responsiveness improving.
Posted Aug 31, 2023 - 16:34 UTC
Investigating
We're seeing increased API latency for a subset of our US customers, leading to a slower experience when using Front's app. (Actions in Front are taking 10-20 seconds to complete in some cases). We're working on identify the root cause and returning the app's responsiveness to normal levels.
Posted Aug 31, 2023 - 15:23 UTC
This incident affected: App.