Delay in messages sent or received over Slack

Incident Report for Front

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 20:00 UTC

Monitoring

There was a delay in message delivery of up to an hour. Messages are now being delivered without delay. We are continuing to monitor
Posted Apr 14, 2026 - 17:03 UTC
This incident affected: Other channels.