Delay in Inbox Counters
Incident Report for Front
Resolved
This incident has been resolved.
Posted Dec 24, 2019 - 02:41 UTC
Investigating
We are currently experiencing a delay in our inbox counters and are investigating.
Posted Dec 24, 2019 - 01:15 UTC
This incident affected: App.