Delays with Twilio sending [twilio]
Incident Report for Front
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 14:38 UTC
Monitoring
Latency is back to normal, we are monitoring.
Posted Oct 09, 2020 - 14:01 UTC
Identified
Some of our users reached out, reporting delays on message sending with Twillio channels.

Twilio is reporting multiple issues on their status page:
https://status.twilio.com/
Posted Oct 09, 2020 - 13:58 UTC
This incident affected: Twilio.