Permission errors on some O365 channels [office365]
Incident Report for Front
Resolved
All Office365 channels that still need to be re-authorized are now correctly identified by in-app warnings. Re-authorizing those channels will resolve send/receive issues.

Note: re-authorization typically needs to be done by an administrator and/or someone with an Office365 login that has the appropriate permissions.
Posted Dec 08, 2023 - 01:27 UTC
Monitoring
All Office365 channels that still need to be re-authorized are now correctly identified by in-app warnings. Re-authorizing those channels will resolve send/receive issues.

Note: re-authorization typically needs to be done by an administrator and/or someone with an Office365 login that has the appropriate permissions.
Posted Dec 07, 2023 - 22:59 UTC
Identified
As a side effect of https://www.frontstatus.com/incidents/1q7f4p99943g , some Office365 channels are failing to send with a "The Office365 account does not have permission to access this mailbox" error, but in actuality these channels need to be re-authorized.

Re-authorizing affected Office365 channels using an Office365 account that has permissions for that inbox should resolve the issue.

We are working to update the UI to correctly prompt for these channels to be re-authorized.
Posted Dec 07, 2023 - 20:02 UTC
Investigating
As a side effect of https://www.frontstatus.com/incidents/1q7f4p99943g some customers reported that their Office365 channels are now showing "The Office365 Account does not have permission to access this mailbox"

Our team is working to find the cause of this error. There is currently no estimated time for a resolution.
Posted Dec 07, 2023 - 15:52 UTC
This incident affected: O365.