Search delays in the US region
Incident Report for Front
Resolved
This incident has been resolved.
Posted Jun 17, 2020 - 21:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 17, 2020 - 21:08 UTC
Investigating
We are investigating search indexing delays in the US region.
Posted Jun 17, 2020 - 20:44 UTC
This incident affected: Search engine.