Delays on O365 channels

Incident Report for Front

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 00:57 UTC

Monitoring

An offending change was identified and reverted. We are monitoring the impact now
Posted Jul 29, 2025 - 23:52 UTC

Investigating

We are experiencing some delays in O365 channels and are actively investigating this issue.
Posted Jul 29, 2025 - 23:41 UTC
This incident affected: O365.