Email delivery issues affecting some Office365 channels [office365][partner]
Incident Report for Front
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 08:21 UTC
Monitoring
Microsoft is still working on a resolution. The incident has been contained to a limited number of customers.
Posted Apr 28, 2022 - 08:10 UTC
Update
Microsoft is still working on a mitigation for this issue.
Posted Apr 28, 2022 - 01:45 UTC
Update
Microsoft has identified the issue and is working on a plan to roll out a fix. We are expecting additional updates on progress within the next two hours.
Posted Apr 27, 2022 - 23:07 UTC
Update
Microsoft is continuing to work on this issue and will continue to work on it around the clock. We do not have an ETA for a mitigation at this time.
Posted Apr 27, 2022 - 22:39 UTC
Update
Microsoft has confirmed that the issues impacting a subset of channels are tied to a service disruption that is affecting multiple users across different organizations. We are still engaged and are awaiting news on mitigations
Posted Apr 27, 2022 - 19:43 UTC
Update
Microsoft has confirmed an issue in the O365 Graph API that is affecting deliverability for a subset of users.
Posted Apr 27, 2022 - 18:16 UTC
Update
We are continuing to work with the Microsoft team as they investigate errors in the O365 API.
Posted Apr 27, 2022 - 17:11 UTC
Update
We are continuing to work with the Microsoft team on this issue.
Posted Apr 27, 2022 - 15:53 UTC
Update
Microsoft is actively investigating errors in the O365 API that are causing email delivery issues for some Office365 channels.
Posted Apr 27, 2022 - 15:42 UTC
Identified
We have reached out to the Microsoft team about elevated errors we are observing in the O365 API causing email delivery issues for some Office365 channels.
Posted Apr 27, 2022 - 13:52 UTC
Update
We have reached out to the Microsoft team about elevated errors we are observing in the O365 API causing email delivery issues for some Office365 channels.
Posted Apr 27, 2022 - 13:47 UTC
Investigating
We are currently investigating this issue.
Posted Apr 27, 2022 - 12:44 UTC
This incident affected: O365.