Search issues in the US region
Incident Report for Front
Resolved
This incident has been resolved.
Posted Jun 04, 2019 - 17:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2019 - 15:21 UTC
Investigating
We are currently investigating the issue.
Searching for conversations, contacts, tags and signatures is unresponsive at the moment.
Posted Jun 04, 2019 - 15:14 UTC
This incident affected: Search engine.