Delays in receiving emails
Incident Report for Front
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 21, 2018 - 15:20 UTC
Identified
We are experiencing a higher than normal load. Some emails will arrive a few minutes late. We expect to fully recover within within 10 mins.
Posted 3 months ago. Feb 21, 2018 - 14:29 UTC