Front is less responsive for some customers in us-west-1 [us-west-1][by-company-00017]
Incident Report for Front
Resolved
This incident has been resolved.
Posted Sep 06, 2023 - 16:53 UTC
Monitoring
The team has implemented measures, and we are beginning to see improvements.
Posted Sep 06, 2023 - 16:39 UTC
Update
We've identified the issue, and our team is actively working on measures to mitigate it.
Posted Sep 06, 2023 - 16:31 UTC
Identified
We're seeing increased API latency and delays in receiving new messages for a subset of our US customers, leading to a slower experience when using Front's app. (Actions in Front are taking 10-20 seconds to complete in some cases).
Posted Sep 06, 2023 - 15:53 UTC
This incident affected: App, Gmail, and O365.