Delays in rules and deliverability of emails for customers

Incident Report for Front

Resolved

All impacted regions updated, customer impact has been resolved.
Posted Oct 26, 2023 - 18:14 UTC

Update

All US West 1 customer events are resolved.
Posted Oct 26, 2023 - 18:10 UTC

Update

All EU West 1 customer events are resolved.
Posted Oct 26, 2023 - 18:09 UTC

Update

Replayed failed events are resolving. Continuing to replay all events in backlog for resolution
Posted Oct 26, 2023 - 17:47 UTC

Monitoring

Replaying failed events for impacted customers. Continuing to monitor impact
Posted Oct 26, 2023 - 17:30 UTC

Update

We are continuing to investigate this issue.
Posted Oct 26, 2023 - 17:23 UTC

Investigating

We are currently investigating this issue.
Posted Oct 26, 2023 - 17:22 UTC
This incident affected: Rules and Workflows, SMTP (non-Gmail / O365), Gmail, and O365.