Delays in receiving messages for some Office365 emails
Incident Report for Front
Resolved
This incident has been resolved.
Posted Mar 23, 2020 - 19:39 UTC
Investigating
We are currently investigating delays in receiving emails for some Office 365 channels.
Posted Mar 23, 2020 - 17:12 UTC
This incident affected: Sync engine.