Outbound delivery delays
Incident Report for Front
Resolved
Outbound delivery performance has returned to normal.
Posted 5 months ago. Dec 22, 2018 - 07:41 UTC
Update
We are continuing to investigate this issue.
Posted 5 months ago. Dec 22, 2018 - 02:48 UTC
Investigating
One of our mail delivery providers is experiencing delivery delays. Only SMTP Inboxes and transactional emails are affected.
Posted 5 months ago. Dec 22, 2018 - 02:47 UTC
This incident affected: SendGrid and Transactional emails.