[office365] Office 365 channel service disrupted
Incident Report for Front
Resolved
All Office365 inboxes should now be operating normally.
Posted Oct 07, 2020 - 22:52 UTC
Update
Microsoft has reported that connections to Office365 Outlook mailboxes are now healthy. We are currently ensuring that all affected mailboxes have fully recovered.
Posted Oct 07, 2020 - 22:40 UTC
Monitoring
We have scaled our infrastructure to mitigate the effects of the slowdown and are monitoring for updates on the O365 service. More info on the O365 service status can be found at https://status.office365.com/
Posted Oct 07, 2020 - 19:02 UTC
Identified
The issue has been identified as a slowdown on the Outlook API. We are working to mitigate the slowdowns to reduce impact on Front users.
Posted Oct 07, 2020 - 18:49 UTC
Investigating
Some Office365 channels are experiencing reduced service due to a connectivity issue between Front and the Office365 service.
Posted Oct 07, 2020 - 18:43 UTC
This incident affected: O365.