GoDaddy is reporting issues for email forwarding
Incident Report for Front
Resolved
GoDaddy now says all systems are operational.
Posted 8 months ago. Sep 26, 2017 - 14:12 UTC
Investigating
Please refer to http://status.godaddy.com/
This issue could be impacting email forwarding and custom SMTP
Posted 8 months ago. Sep 25, 2017 - 22:08 UTC