Delays in sending outbound mail for SMTP channels
Incident Report for Front
Resolved
This incident has been resolved.
Posted Feb 20, 2020 - 18:38 UTC
Monitoring
We are no longer seeing delays in outbound mail from SMTP channels. We'll continue to monitor.
Posted Feb 20, 2020 - 18:30 UTC
Investigating
We are currently investigating delays in outbound emails from SMTP channels. Users may experience delays of up to 15 minutes before sent mail is delivered. We expect the issue to be resolved within 15-30 minutes.
Posted Feb 20, 2020 - 18:24 UTC
This incident affected: SMTP (non-Gmail / O365) and Transactional emails.