Microsoft Office is having issues and can affect Front channels [office365] [partner]
Incident Report for Front
Resolved
This incident has been resolved.
Posted Mar 16, 2021 - 04:13 UTC
Update
Per Microsoft's official status regarding the incident: "Our actions to remediate impact across all of our Microsoft 365 services are ongoing. We're continuing to receive positive feedback that some Microsoft 365 services are fully recovered"

source: https://status.office.com/
Posted Mar 16, 2021 - 02:19 UTC
Monitoring
Microsoft said the issues was resolved. We're keeping an eye on their status page.

"The update has finished deployment to all impacted regions. Microsoft 365 services are showing decreasing error rates in telemetry. We’ll continue to monitor service health status. Additional information can be found at http://status.office.com."

Source: https://twitter.com/MSFT365Status/status/1371581388508573698
Posted Mar 15, 2021 - 22:00 UTC
Update
Microsoft updated their status page with the following information:

"We are currently rolling out a mitigation worldwide. Customers should begin seeing recovery at this time, and we anticipate full remediation within 60 minutes. Additional information can be found at http://status.office.com or under MO244568 if available."

source: https://twitter.com/MSFT365Status/status/1371571383004590081
Posted Mar 15, 2021 - 21:33 UTC
Identified
Microsoft has identified the issue and are working on a fix:
"We've identified an issue with a recent change to an authentication system. We’re rolling back the update to mitigate impact, which we expect will take approximately 15 minutes. Additional information can be found at http://status.office.com or under MO244568 if available."

Source: https://twitter.com/MSFT365Status/status/1371554704518352896
Posted Mar 15, 2021 - 20:36 UTC
Investigating
Microsoft has started to acknowledge issues with their Office 365 Suite.
From their official account about the incident:
"We're investigating an issue for access to multiple M365 services. Please visit the admin center post M0244568 for more information. We'll provide additional information here as it becomes available."

Source: https://twitter.com/MSFT365Status/status/1371546946263916545
Posted Mar 15, 2021 - 19:48 UTC
This incident affected: O365.