Delays in processing Office 365 incoming messages
Incident Report for Front
Resolved
All messages in our backlog have been processed.
Posted 4 months ago. Jan 17, 2018 - 23:12 UTC
Identified
We currently have a backlog of incomings messages for Office 365. We expect this to be resolved soon.
Posted 4 months ago. Jan 17, 2018 - 22:45 UTC