Slowness on the app
Incident Report for Front
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 19, 2019 - 18:56 UTC
Monitoring
We are continuing to monitor for any further issues.
Posted 3 months ago. Apr 19, 2019 - 18:42 UTC
Investigating
Some customers might encounter some slowness on the app. Our team is working on resolving the issue
Posted 3 months ago. Apr 19, 2019 - 18:08 UTC
This incident affected: App.