Office365 Channels: Elevated Latency & Error Rate from Microsoft
Incident Report for Front
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 22:47 UTC
Monitoring
Our systems are recovering and should be fully functional soon. We will continue to monitor the situation
Posted Mar 17, 2020 - 22:19 UTC
Identified
We believe we have identified the root cause of the issue, and have seen Office365 error rates return to normal levels. We are working on replaying past failed operations. Any new O365 messages/2-way sync operations will be handled in real-time time.
Posted Mar 17, 2020 - 22:00 UTC
Update
We continue to investigate the root cause of the elevated errors that has occurred since ~12:15 Pacific time. The overall error rate has decreased but we still see some delays in sent message processing.
Posted Mar 17, 2020 - 21:21 UTC
Investigating
We are investigating an elevated number of errors for Office365 channels related to increased latency in our communication with the Microsoft API. This may result in delays in incoming messages and 2-way sync.
Posted Mar 17, 2020 - 20:44 UTC
This incident affected: Sync engine.