Delays in search in the US
Incident Report for Front
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 18:22 UTC
Monitoring
A fix has been implemented and we are monitoring results.
Posted Jun 16, 2020 - 18:06 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 16, 2020 - 18:05 UTC
Investigating
Search results may be delayed in the US. We are currently investigating this issue.
Posted Jun 16, 2020 - 17:55 UTC
This incident affected: Search engine.