We are not able to deliver emails through one of our sending providers
Incident Report for Front
Resolved
We are continuing to work towards a resolution with our sending provider. If you have been affected by this incident, your company admins have received an email with more details and next steps.
Posted 3 months ago. Jul 30, 2019 - 09:03 UTC
Update
We are continuing to work towards a resolution with our sending provider. If you have been affected by this incident, your company admins have received an email with more details and next steps.
Posted 3 months ago. Jul 30, 2019 - 02:59 UTC
Update
We are working closely with our sending provider to restore service. We are pursuing the fix that will minimize impact to affected customers.
Posted 3 months ago. Jul 29, 2019 - 22:42 UTC
Update
If you became a Front customer before mid-2017, you may be affected by this outage. We are working on a few solutions to restore sending capabilities for affected customers. If you are experiencing deliverability issues, please reach out to us at support@frontapp.com.
Posted 3 months ago. Jul 29, 2019 - 21:53 UTC
Identified
We are working on a fix. We are also working to identify affected customers and inboxes. If you are experiencing deliverability issues, please reach out to us at support@frontapp.com
Posted 3 months ago. Jul 29, 2019 - 21:06 UTC
This incident affected: Mandrill.