Front inaccessible to some EU customers
Incident Report for Front
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 17, 2019 - 15:17 UTC
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Jul 17, 2019 - 14:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jul 17, 2019 - 14:14 UTC
Investigating
We received reports of users being unable to access Front in Europe. We are investigating
Posted 3 months ago. Jul 17, 2019 - 14:08 UTC
This incident affected: App.