Outbound delivery delays
Incident Report for Front
Resolved
We've been notified that the issue is resolved and all delayed mail has now been sent.
Posted Feb 20, 2020 - 03:55 UTC
Monitoring
Update from Sendgrid: "We have confirmed the subset of delayed mail has fully dequeued. We’re currently monitoring system performance. We apologize for any inconvenience this may have caused. Please contact our Support team at https://support.sendgrid.com with any questions."
Posted Feb 20, 2020 - 02:44 UTC
Identified
Update from Sendgrid: "We've confirmed that new mail received is being processed and delivery is attempted as normal. We are currently working to dequeue the subset of mail that was delayed between approximately 4:30 pm MT and 5:00 pm MT. We will continue to update as that mail dequeues."
Posted Feb 20, 2020 - 01:41 UTC
Investigating
One of our mail delivery providers is experiencing delivery delays. Only SMTP Inboxes and transactional emails are affected. For more information see: https://status.sendgrid.com/incidents/637d8tg2tt5z
Posted Feb 20, 2020 - 01:16 UTC
This incident affected: SendGrid and Transactional emails.