Messages sent to Mimecast inboxes may fail to be delivered
Incident Report for Front
Resolved
This incident has been resolved.
Posted 4 months ago. May 14, 2019 - 05:43 UTC
Update
We are in contact with Mimecast and are working with them towards a solution.
Posted 4 months ago. May 14, 2019 - 00:55 UTC
Identified
Mimecast is an email security service your contacts may use to detect spam. You will receive a bounce error for any failed messages. Our investigation suggests that delivery failures are not specific to Front. We have contacted Mimecast for more information.
Posted 4 months ago. May 13, 2019 - 20:47 UTC