Delayed inbound mail for some Office365 inboxes [office365]
Incident Report for Front
Resolved
We have confirmed the mitigation put in place is working correctly and delayed messages are now being delivered as we develop a long-term preventative fix.
Posted Sep 03, 2021 - 01:33 UTC
Monitoring
We have applied a mitigating fix to catch and deliver inbound messages delayed as a result of Office365 channel service disruptions. A long-term fix has been identified and we are monitoring to confirm the mitigation is working as expected.
Posted Sep 03, 2021 - 01:13 UTC
Identified
We have identified an issue causing delays in inbound messages for some Office365 email channels. We are currently working to mitigate the issue and resolve the service disruption.
Posted Sep 02, 2021 - 23:33 UTC
This incident affected: O365.